Installation of Operating system and package repository for
Oracle Solaris 11.
Step-1: Oracle Solaris 11 OS installation.
ok boot cdrom
once the installation is completed the system prompts for a reboot.
Reboot the server.
Step-2: Giving direct login access to root.
In solaris 11, a default user will be created at the time of
installation and it will be the default login to get into the OS prompt. Log in
to that user and switch to root user from there.
Now as a root user you can set root as the default login for your
Solaris 11 operating system.
In /etc/user_attr file by
default an entry exists as below,
root::::type=role
this root type value should be set to normal, so as you can get the
direct root access.
root::::type=normal
Step-3: Plumbing interface and assigning ip address
Check the physical interfaces available.
# dladm show-phys
Plumb the interfaces which you need using the below command.
# ipadm create-ip net#
If the ip is not provided at the time of OS installation, then assign
an ip address for the interface which you plumbed.
# ipadm create-addr –T static
–a 192.168.1.10/24 net#/v4
# ifconfig –a4
Add default gateway using the below command.
# route –p add default 192.168.1.1
Step-5: Preparing for the installation of the repository.
Copy and concatenate the package repository images
Two repository images are available for the package installation in
Solaris 11.
sol-11-1111-repo-full-iso-a
sol-11-1111-repo-full-iso-b
These both image should be copied into the host and it should be
concatenated to form a single .iso image.
# cat sol-11-1111-repo-full-iso-a
sol-11-1111-repo-full-iso-b > sol-11-1111-repo-full-iso
Mount the .iso file as a hsfs filesystem.
# mount -F hsfs /repoimage/sol-repo.iso /mnt
Create a ZFS file system.
# zfs create rpool/pkg
Now sync the iso image within /rpool/pkg
# rsync -aP /mnt/repo /rpool/pkg
Then
# umount /mnt
Now refresh the package repository
# pkgrepo rebuild -s /rpool/pkg/repo
Verify that the package repository is online and so it is ready to
install
# pkgrepo info -s /rpool/pkg/repo
Add the package repository to the publisher
# pkg set-publisher -G '*' -g
file:///rpool/pkg/repo solaris
Where -G '*' removes the current publisher.
Now check publisher
# pkg publisher
Set the application/pkg/server service pkg/inst_root property to the
repository location.
# svccfg -s application/pkg/server setprop
pkg/inst_root=/rpool/pkg/repo
Set the application/pkg/server service pkg/readonly property to true
# svccfg -s application/pkg/server setprop
pkg/readonly=true
Refersh the application/pkg/server service
# svcadm refresh application/pkg/server
Enable the application/pkg/server service
# svcadm enable application/pkg/server
Verify that the service is enabled
# svcs -a | grep application/pkg/server
Now install the package repository which installs all the recommended
packages within the OS.
Step-6: Installation of package repository
# pkg install all
This may take some time, wait until the prompt appears.
After check the installed package repository information.
# pkg info entire
Step-7: Getting GUI for Solaris 11 operating system.
To get the graphical user interface for Solaris 11 operating system a
package has to be installed.
# pkg search slim_install
# pkg install slim_install
Then edit /etc/gdm/custom.conf file
An entry should be made below the line
[xdmcp]
Enable=true
Set the application/x11/x11-server service options/tcp_listen property
to true
# svccfg -s
svc:/application/x11/x11-server setprop options/tcp_listen=true
# svcadm restart gdm
# svcs -a | grep gdm
offline 14:26:14
svc:/application/graphical-login/gdm:default
Now reboot the server and you will get the graphical user interface for
solaris 11 operating system.
Step-8: Updating the package repository.
Copy the update repository .iso image to the host.
Mount the update package repository .iso image in a directory
#mkdir /repoupdate
# mount –F hsfs <.iso file path> /repoupdate
Add the update package repository to the publisher.
Verify the published repositories.
# pkg publisher
Before updating check the update level of current repository.
# pkg info entire
Update the current repository.
# pkg update
Oracle SPARC Virtual Machine configuration.
Configure the Primary LDOM.
Step-1: Initializing LDOM manager.
Check whether LDOM manager is online.
# svcs –a | grep ldmd
If not online initialize LDOM manager
# ldmd
Step-2: Adding services to primary domain.
Adding virtual disk service to primary domain.
# ldm
add-vds primary
Adding virtual console service to primary domain
# ldm add-vcc port-range=5000-5100
primary
Adding virtual switch service to the primary domain
# ldm add-vsw
net-dev= primary
Listing all the added services in the primary domain.
# ldm list-services primary
Step-3: Adding hardware resources to primary domain.
Adding mau for cryptographic purpose
# ldm set-mau 0 primary
Adding virtual CPU to primary domain.
# ldm set-vcpu 4 primary
Adding memory to primary domain.
# ldm set-memory 4G primary
Step-4: Saving the configuration and rebooting.
Saving the basic configuration.
# ldm add-config initial.
To list the current configuration
# ldm list-config
Reboot the server.
# touch /reconfigure
# shutdown –y –g0 –i6
After this reboot the server comes up with the primary domain configured
with all its services and resources.
Step-5: Enabling virtual network services daemon.
Check virtual network service daemon.
# svcs –a | grep vntsd
Enable virtual network service daemon.
# svcadm enable vntsd
Step-6: Creating guest domain and adding resources to it.
Adding guest domain name.
# ldm add-domain
Adding virtual CPU to guest domain.
# ldm add-vcpu 20
Adding memory to guest domain.
# ldm add-memory 5g
Adding virtual network to guest from the virtual switch available in
primary.
# ldm add-vnet
Creating a ZFS file system in the local/external disk of primary
# zfs create -V 50g
Adding root disk to primary and into guest domain
# ldm add-vdsdev
/dev/zvol/dsk/rpool/rootdisk_ldm1
# ldm add-vdisk
Step-7: Verifying and preparing for guest domain OS
installation.
Bind guest domain to primary domain.
# ldm bind-domain
List the domains configured in the server
# ldm list
List the information of guest domain and its resources.
# ldm list-bindings
Set the auto-boot variable to true for guest domain.
# ldm set-var auto-boot\?=true
Set the boot device variable to vdisk for guest domain.
# ldm set-var
boot-device=vdisk
Add the Solaris_OS.iso image to guest domain for installation.
# ldm add-vdsdev <.iso
image path>
# ldm add-vdisk cdrom ldm1
Step-8: Guest domain OS installation.
Start the guest domain
# ldm list-domain
# ldm start
telnet to get console of guest domain.
# telnet localhost 5000
(Where 5000 is the vcc port assigned by the LDOM manager to guest
domain.)
Now the guest console will be in OK prompt. Now start the installation
of Solaris OS.
ok boot cdrom
Oracle Solaris Cluster configuration.
1. Check whether cluster repository is
already published.
# pkg publisher
PUBLISHER TYPE STATUS
URI
2. Mount the solaris cluster 4.0
repository iso image to a mount point.
# mount -F hsfs /cluster_bin/osc4.0a-repo-full.iso
/mnt
3. Publish the mount point which has the
cluster repository image
# pkg set-publisher -p file:///mnt/repo
pkg set-publisher: Added publisher(s): ha-cluster
#
4. Check whether cluster image is added
to the publisher list.
# pkg publisher
PUBLISHER TYPE
STATUS URI
solaris origin online
file:///rpool/pkg/repo/
5. Install the oracle solaris cluster
4.0 packages.
# pkg install ha-cluster-full
6. Install solaris cluster 4.0 with
scinstall command and by following its underlying menus.
# scinstall
7. Adding DID devices, adding creating
and adding resource groups and resources are same as in the previous versions
of sun cluster.
No comments:
Post a Comment